Forums now use https://

This is used for general discussion that is not necessarily server-related.
Post Reply
User avatar
Edge100x
Founder
Founder
Posts: 12279
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Forums now use https://

Post by Edge100x » Wed Sep 23, 2015 3:10 pm

These forums now use an encrypted (TLS) connection, as our main site and control panel do. Any time you visit an official NFOservers page, you should be served encrypted content.

User avatar
TacTicToe
This is my homepage
This is my homepage
Posts: 846
Joined: Fri Feb 18, 2011 1:08 pm
Location: USA
Contact:

Re: Forums now use https://

Post by TacTicToe » Wed Sep 23, 2015 3:23 pm

How very cryptive. 8)
Image

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: Forums now use https://

Post by soja » Wed Sep 23, 2015 4:21 pm

I was never really a fan of https on forums, mainly because my users aren't very tech savvy, and they see the yellow padlock(since forums contain user-content like sigs or embedded images) and think something is wrong on our site.

I am happy the forums use https now though, the more secure the better :)
Not a NFO employee

User avatar
Edge100x
Founder
Founder
Posts: 12279
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Forums now use https://

Post by Edge100x » Wed Sep 23, 2015 4:23 pm

The yellow padlock is annoying, I agree. Unfortunately, there's no way around it.

theRadAleks
This is my homepage
This is my homepage
Posts: 198
Joined: Wed Feb 19, 2014 6:07 pm
Location: Dallas, TX

Re: Forums now use https://

Post by theRadAleks » Thu Sep 24, 2015 2:56 pm

It's only yellow when you are viewing a post but everything else is green for me.

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: Forums now use https://

Post by soja » Thu Sep 24, 2015 2:58 pm

theRadAleks wrote:It's only yellow when you are viewing a post but everything else is green for me.
It is yellow whenever the page contains content delivered from an insecure source. This usually means embedded images in signatures and/or posts, as I said before.
Not a NFO employee

noname
A semi-regular
A semi-regular
Posts: 16
Joined: Thu Dec 18, 2014 7:55 am

Re: Forums now use https://

Post by noname » Sun Oct 04, 2015 11:17 pm

Bravo, good move.

Bubka3
Compulsive poster
Compulsive poster
Posts: 68
Joined: Fri Feb 21, 2014 10:24 am

Re: Forums now use https://

Post by Bubka3 » Sat Oct 10, 2015 5:49 pm

Xenforo forum software gets around that by proxy/caching all the images on the forums locally, and serving it over HTTPs.

Very neat feature!

Post Reply