Brain Bread 2

Use this forum if you have a relatively general question or comment about a game, Ventrilo, TeamSpeak, or Murmur/Mumble server with us. If you have a server-specific question that might not help out the community, please directly contact us through your control panel instead.
Post Reply
User avatar
TacTicToe
This is my homepage
This is my homepage
Posts: 846
Joined: Fri Feb 18, 2011 1:08 pm
Location: USA
Contact:

Brain Bread 2

Post by TacTicToe » Sun Aug 28, 2016 9:23 am

So I seem to have an issue with this game. I installed it via the SteamCMD, have it setup and config'ed but it does not work. Server is online, you can connect directly via IP:PORT and it appears in my Favorites list, but it will not appear in the browser and returns this error.
Server is hibernating
Could not establish connection to Steam servers. (Result - 106)
I have tried changing the ports and IPs. No difference.

I added the command "sv_hibernate_when_empty 0" to the server.cfg

I added the command "+sv_hibernate_when_empty 0" to the command line.

I have created a server id token and my account is in good standing.

You can connect directly in console with

connect 192.223.30.23:27018

Server steamcmd is 475370

I can not find anything on the internet in regards to this error code. The devs do not seem to understand what is causing it as well. They seem to only run on a Linux setup, so I am thinking the Windows server was not properly tested.

Any ideas?
Image

User avatar
Edge100x
Founder
Founder
Posts: 12222
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Brain Bread 2

Post by Edge100x » Mon Aug 29, 2016 10:21 pm

You may be right about them just not testing it on Windows. It's possible that the Windows Steam libraries behave slightly differently.

You might try copying over the dlls from the directory that you run steamcmd.exe from -- sometimes that helps.

Since it sounds like the game is based on L4D/L4D2, you might also try setting stuff like this:

sv_allow_lobby_connect_only 0
sv_search_key ""
sv_steamgroup_exclusive 0
sv_steamgroup ""

User avatar
TacTicToe
This is my homepage
This is my homepage
Posts: 846
Joined: Fri Feb 18, 2011 1:08 pm
Location: USA
Contact:

Re: Brain Bread 2

Post by TacTicToe » Wed Aug 31, 2016 4:50 am

As it turns out, they instructed us to create and use a Steam Server ID token, which I did. Using that caused the issue. One of the developers told me to remove it and try and that worked. Server launches and connects to the steam servers fine now and people are connecting normally.

So if anyone else wishes to run Brainbread 2 off their Windows box, do not use the token when launching this server.

Problem solved.

Thanks!
Image

Post Reply