Upgraded ubuntu 10.04 to 12.04 and now networking doesn't wo

Ask questions about dedicated servers here and we and other users will do our best to answer them. Please also refer to the self-help section for tutorials and answers to the most commonly asked questions.
Post Reply
rivanor
New to forums
New to forums
Posts: 11
Joined: Mon Dec 06, 2010 4:31 pm

Upgraded ubuntu 10.04 to 12.04 and now networking doesn't wo

Post by rivanor » Tue Oct 16, 2012 10:02 am

Hi all,

I just took the plunge and did "do-release-upgrade" on my Ubuntu 10.04 LTS VDS, figuring that the upgrade should be stable enough by now to "just work".

Upon rebooting, I could no longer SSH into the box but fortunately the VNC java thingy from the control panel worked so I was able to tinker around enough with the machine to figure out that networking doesn't seem to work on the latest kernel. I found a post here about this: http://old-list-archives.xen.org/archiv ... 02154.html . I don't know if this is related or not BUT since it appears we can re-install a fresh 12.04 LTS install from the control panel, I assume that the NFO guys have figured out how to make it work.

I've temporarily gotten networking working again by booting to the older kernel version (2.6.32-44-server) but I am going to need a more permanent solution since I can't always be manually choosing which kernel to boot to.

Gonna try linux-image-3.2.0-32-virtual and see if that works better than 3.2.0-32-generic but any other advice would be appreciated.

User avatar
Edge100x
Founder
Founder
Posts: 12359
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Upgraded ubuntu 10.04 to 12.04 and now networking doesn'

Post by Edge100x » Tue Oct 16, 2012 10:19 am

A number of other people have tried that upgrade and I don't think I've ever seen it work right. Here's someone who tried it recently: http://www.nfoservers.com/forums/viewto ... =44&t=7777.

The problem seems to be with the upgrade script and how it handles the Xen PV adapter.

rivanor
New to forums
New to forums
Posts: 11
Joined: Mon Dec 06, 2010 4:31 pm

Re: Upgraded ubuntu 10.04 to 12.04 and now networking doesn'

Post by rivanor » Tue Oct 16, 2012 10:23 am

dang, I tried searching for "12.04" to see if there were any other threads about it but got a search error. My bad.

so fresh install works, upgrade doesn't work?

User avatar
Edge100x
Founder
Founder
Posts: 12359
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Upgraded ubuntu 10.04 to 12.04 and now networking doesn'

Post by Edge100x » Tue Oct 16, 2012 10:58 am

phpBB's search function is unfortunately not very good :|.

Yes, that is my understanding, though I'm not certain whether the OP of that thread followed up and had me check the Xen version.

Post Reply