Punkbuster outdated?

BooYahRadley
New to forums
New to forums
Posts: 4
Joined: Tue Mar 12, 2013 8:51 am

Punkbuster outdated?

Post by BooYahRadley » Wed Mar 13, 2013 4:42 pm

Hey,

Loving my servers here so far. I set them up to stream PBBans and GGC and it's working but I noticed on GGC's page that the version of punkbuster my servers are running is outdated (v 1.826 vs. 1.863). I ran pb_sv_update through both of my procon layers and get a message about no dns resolution to master6.evenbalance.com. I'm new to BF3 admin and am just wondering if this is normal or, if not, how I could go about fixing it? I promise that I searched the forums here first and didn't see any topics with this issue. If I missed one, all apologies.

TIA

User avatar
Sorry
This is my homepage
This is my homepage
Posts: 111
Joined: Fri Jun 03, 2011 4:26 pm
Contact:

Re: Punkbuster outdated?

Post by Sorry » Wed Mar 13, 2013 7:48 pm

Try this command in the procon console tab, punkBuster.pb_sv_command pb_sv_update

BooYahRadley
New to forums
New to forums
Posts: 4
Joined: Tue Mar 12, 2013 8:51 am

Re: Punkbuster outdated?

Post by BooYahRadley » Thu Mar 14, 2013 12:04 am

Tried it on both Procon Layers (both of which are laid over nfoservers.com BF3 gameservers). No change. I tried your suggested command and then pb_sv_update in the Punkbuster part of the Console.

3 images: http://imgur.com/a/bK618

Thanks for any help and I very much appreciate your assistance, Sorry. It just hasn't fixed my problem. I'm really leaning toward user error on my part but I'm just not sure what to do. GGz

BrendanG
Staff
Staff
Posts: 366
Joined: Mon Nov 06, 2006 2:55 pm

Re: Punkbuster outdated?

Post by BrendanG » Thu Mar 14, 2013 6:21 am

BooYahRadley: have you sent in a support request for this issue? I know John has send out a system wide command to update the base files for PB so this should not be an issue. However running a repair may be a way to get this resolved. So please send in a request if this has not yet been resolved.

User avatar
Edge100x
Founder
Founder
Posts: 12218
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Punkbuster outdated?

Post by Edge100x » Thu Mar 14, 2013 9:33 am

PB has always been pretty unreliable when it comes to updating automatically. I recommend having us run a repair operation on your server (or, if you have a managed server, you can do this through the "Managed panel" page). We manually update the base files using PBsetup to make sure that they're correct, and this will sync your server's up with those.

BooYahRadley
New to forums
New to forums
Posts: 4
Joined: Tue Mar 12, 2013 8:51 am

Re: Punkbuster outdated?

Post by BooYahRadley » Thu Mar 14, 2013 11:50 am

Thanks for the replies, edge if you guys can do that I'd really appreciate it. Should I do as Brendan suggested and open the ticket? And thanks, Brendan, I'm just now seeing these otherwise I would have done as you suggested.

User avatar
Edge100x
Founder
Founder
Posts: 12218
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Punkbuster outdated?

Post by Edge100x » Thu Mar 14, 2013 11:52 am

Yes, opening a support request would be best. We should be able to take care of this for you quickly.

BooYahRadley
New to forums
New to forums
Posts: 4
Joined: Tue Mar 12, 2013 8:51 am

Re: Punkbuster outdated?

Post by BooYahRadley » Thu Mar 14, 2013 11:56 am

Awesome, I appreciate the help. Have a good day all.

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Re: Punkbuster outdated?

Post by TimSad » Mon Apr 15, 2013 12:00 pm

Too bad I didn't pay any heed to this thread when it first popped up. Without realizing it, my servers have been running an outdated PB version for more than a month now and the only way they are gonna update is by manually updating them.

Unfortunately, the control panel is telling me I can't put the required file in my servers' PB directory to manually update for some reason so I've had to open up a ticket. Are your servers in LA as well, BoohYah? Trying to figure out why exactly the queries weren't being sent for the update...

http://www.pbbans.com/forums/--t164419. ... ntry440207
                                                Our NFO Battlefield Servers!
ImageImage
Image

User avatar
Edge100x
Founder
Founder
Posts: 12218
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Punkbuster outdated?

Post by Edge100x » Mon Apr 15, 2013 12:59 pm

TimSad, as we mentioned above, just open a support request and ask us to run a repair operation on the server to fix PB for you.

PB rarely updates correctly. EvenBalance also messed up the most recent update so even PBSetup didn't work for a week or so (no servers had the update during that time, as a result).

jaythegreat1
This is my homepage
This is my homepage
Posts: 193
Joined: Fri Feb 24, 2012 9:49 am

Re: Punkbuster outdated?

Post by jaythegreat1 » Mon Apr 15, 2013 5:16 pm

Don't worry TimSad... were in the same boat.
Image
Chill n Kill Gaming - http://www.cnkgaming.com

User avatar
Edge100x
Founder
Founder
Posts: 12218
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Punkbuster outdated?

Post by Edge100x » Mon Apr 15, 2013 5:45 pm

Pretty much everyone is. PB has always had auto-update problems, for some reason. Luckily, it's an easy fix (due to our system design, which was meant to deal with this).

PB is also refreshed with every game update.

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Re: Punkbuster outdated?

Post by TimSad » Tue Apr 23, 2013 11:26 pm

Weird! With all these ban waves, I'm still catching no hackers among all of my servers. It's been well over a month since my last caught hacker still.
                                                Our NFO Battlefield Servers!
ImageImage
Image

User avatar
Buff
New to forums
New to forums
Posts: 3
Joined: Wed May 01, 2013 10:40 am

Re: Punkbuster outdated?

Post by Buff » Wed May 01, 2013 11:15 am

Hi Edge100x,

Can you please check the servers in this topic?

There must be something wrong with them, several admins have discussed this on the forum of PBBans. These servers are streaming to PBBans and we haven't seen one single ban from Punkbuster since February, while hundreds of hackers are being caught?

Our server with IP 74.91.115.201:25200 has the latest PB version 1.867, but I think it's something else. Do we have to open a support ticket?

User avatar
Edge100x
Founder
Founder
Posts: 12218
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Punkbuster outdated?

Post by Edge100x » Wed May 01, 2013 11:43 am

Buff, that is something that we are unlikely to be able to troubleshoot very well from our end, as we don't have visibility into pbbans or how it issues its bans. If they're trying to push commands to the game servers and aren't able to do so, their system should generate errors that they can use to troubleshoot on their end, though.

But, open a support request and I'll take a look at the PB logs and see if I can find anything.

Post Reply