[Pixelmon] works on local machine, won't on FTP.

Post Reply
pandaman212
New to forums
New to forums
Posts: 6
Joined: Thu Jun 25, 2015 7:56 pm

[Pixelmon] works on local machine, won't on FTP.

Post by pandaman212 » Mon Jun 29, 2015 6:44 pm

So I scratched the idea of a FTB server and went with a Pixelmon server. It works perfectly on my local machine but as soon as I put it in the FTP and choose which jar to run (the same one on my local machine) it throws out this

Code: Select all

>l [21:35:43 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
>l [21:35:43 INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
i>lis [21:35:43 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweaker
>list [21:35:43 INFO]: Forge Mod Loader version 7.99.4.1481 for Minecraft 1.7.10 loading
>list
[21:35:43 INFO]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.7.0_76, running on Linux:amd64:3.18.4-nfo, installed at /opt/oracle-jre-bin-1.7.0.76
> [21:35:43 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
> [21:35:43 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
> [21:35:43 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
> [21:35:43 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>> [21:35:43 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
> [21:35:45 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
> [21:35:45 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
> [21:35:45 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
> [21:35:46 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
> [21:35:46 INFO]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
> [21:35:48 INFO]: Launching wrapped minecraft {net.minecraft.server.MinecraftServer}
> [21:35:54 INFO]: Starting minecraft server version 1.7.10
> [21:35:54 INFO]: Attempting early MinecraftForge initialization
> [21:35:54 INFO]: Completed early MinecraftForge initialization
> [21:35:54 ERROR]: Encountered an unexpected exception
java.lang.NoClassDefFoundError: Could not initialize class net.minecraftforge.common.ForgeVersion
at net.minecraftforge.common.ForgeModContainer.<init>(ForgeModContainer.java:82) ~[ForgeModContainer.class:1.7.10-1481.139]
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.7.0_76]
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.7.0_76]
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.7.0_76]
at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.7.0_76]
at java.lang.Class.newInstance(Unknown Source) ~[?:1.7.0_76]
at cpw.mods.fml.common.Loader.identifyMods(Loader.java:340) ~[Loader.class:1.7.10-1481.139]
at cpw.mods.fml.common.Loader.loadMods(Loader.java:489) ~[Loader.class:1.7.10-1481.139]
at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87) ~[FMLServerHandler.class:1.7.10-1481.139]
at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:319) ~[FMLCommonHandler.class:1.7.10-1481.139]
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:176) ~[lt.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:631) [MinecraftServer.class:?]
at java.lang.Thread.run(Unknown Source) [?:1.7.0_76]
> [21:35:54 ERROR]: This crash report has been saved to: /servers/twoc1c/minecraft/./crash-reports/crash-2015-06-29_21.35.54-server.txt
> [21:35:54 WARN]: Can't revert to frozen GameData state without freezing first. 
> [21:35:54 INFO]: Applying holder lookups 
> [21:35:54 INFO]: Holder lookups applied 
> [21:35:54 INFO]: The state engine was in incorrect state CONSTRUCTING and forced into state SERVER_STOPPED. Errors may have been discarded. 
>
Here is what is in the crash report

Code: Select all

---- Minecraft Crash Report ----
// Don't do that.

Time: 6/29/15 9:35 PM
Description: Exception in server tick loop

java.lang.NoClassDefFoundError: Could not initialize class net.minecraftforge.common.ForgeVersion
	at net.minecraftforge.common.ForgeModContainer.<init>(ForgeModContainer.java:82)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.lang.Class.newInstance(Unknown Source)
	at cpw.mods.fml.common.Loader.identifyMods(Loader.java:340)
	at cpw.mods.fml.common.Loader.loadMods(Loader.java:489)
	at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87)
	at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:319)
	at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:176)
	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:631)
	at java.lang.Thread.run(Unknown Source)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
	Minecraft Version: 1.7.10
	KCauldron Version: pw.prok:KCauldron:1.7.10-1481.139
	Operating System: Linux (amd64) version 3.18.4-nfo
	Java Version: 1.7.0_76, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 753309112 bytes (718 MB) / 1012924416 bytes (966 MB) up to 1849163776 bytes (1763 MB)
	JVM Flags: 2 total; -XX:PermSize=64M -Xmx1984M
	AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	FML: MCP v9.05 FML v7.10.99.99 2 mods loaded, 0 mods active
	States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
		mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) 
		FML{7.10.99.99} [Forge Mod Loader] (KCauldron-1.7.10-1481.139-server.jar) 
	Profiler Position: N/A (disabled)
	Is Modded: Definitely; Server brand changed to 'kcauldron,cauldron,craftbukkit,mcpc,fml,forge'
	Type: Dedicated Server (map_server.txt)

User avatar
Vanderburg
Staff
Staff
Posts: 1133
Joined: Sat Nov 13, 2010 7:27 am
Location: Dallas, TX

Re: [Pixelmon] works on local machine, won't on FTP.

Post by Vanderburg » Mon Jun 29, 2015 7:06 pm

Have you run the server locally, then uploaded the server with the generated files to the game server? It often doesn't work well to upload the core files and have the server generate those files remotely.

pandaman212
New to forums
New to forums
Posts: 6
Joined: Thu Jun 25, 2015 7:56 pm

Re: [Pixelmon] works on local machine, won't on FTP.

Post by pandaman212 » Mon Jun 29, 2015 7:20 pm

Yup, I had prepared the server locally to generate all the files and then transferred it to the FTP server. Sorry, I should have been more clear.

pandaman212
New to forums
New to forums
Posts: 6
Joined: Thu Jun 25, 2015 7:56 pm

Re: [Pixelmon] works on local machine, won't on FTP.

Post by pandaman212 » Mon Jun 29, 2015 8:01 pm

Welp, this is awkward now it doesn't seem to want to run on my local machine after switching from java 8 to java 7 to see if that would work because the servers are running java 7. But after reverting it back to 8 it doesn't want to work on local.

Code: Select all

D:\Users\Bb\Downloads\Temp\Server stoof\Pixelmon test 2>Java -Xmx1024M -X
ms1024M -jar KCauldron-1.7.10-1481.139-server.jar
A problem occurred running the Server launcher.java.lang.reflect.InvocationTarge
tException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.j
ava:43)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.
java:12)
Caused by: java.lang.ExceptionInInitializerError
        at org.apache.logging.log4j.util.PropertiesUtil.<init>(PropertiesUtil.ja
va:71)
        at org.apache.logging.log4j.util.PropertiesUtil.<clinit>(PropertiesUtil.
java:31)
        at org.apache.logging.log4j.status.StatusLogger.<clinit>(StatusLogger.ja
va:48)
        at org.apache.logging.log4j.LogManager.<clinit>(LogManager.java:44)
        at net.minecraft.launchwrapper.LogWrapper.configureLogging(LogWrapper.ja
va:14)
        at net.minecraft.launchwrapper.LogWrapper.log(LogWrapper.java:28)
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
        ... 6 more
Caused by: java.lang.NullPointerException
        at org.apache.logging.log4j.util.ProviderUtil.<clinit>(ProviderUtil.java
:70)
        ... 14 more

D:\Users\Bb\Downloads\Temp\Server stoof\Pixelmon test 2>PAUSE
Press any key to continue . . .

pandaman212
New to forums
New to forums
Posts: 6
Joined: Thu Jun 25, 2015 7:56 pm

Re: [Pixelmon] works on local machine, won't on FTP.

Post by pandaman212 » Mon Jun 29, 2015 8:23 pm

Mother of all wtf. The local server now works.

User avatar
Vanderburg
Staff
Staff
Posts: 1133
Joined: Sat Nov 13, 2010 7:27 am
Location: Dallas, TX

Re: [Pixelmon] works on local machine, won't on FTP.

Post by Vanderburg » Mon Jun 29, 2015 11:49 pm

So it looks like it is working normally on Java 8, but not Java 7?

pandaman212
New to forums
New to forums
Posts: 6
Joined: Thu Jun 25, 2015 7:56 pm

Re: [Pixelmon] works on local machine, won't on FTP.

Post by pandaman212 » Tue Jun 30, 2015 3:46 am

That's what my assumption would be. I need still need to test it in a new environment to be sure.

Post Reply