CS:S rates revert to 66

Post Reply
doulos9
This is my homepage
This is my homepage
Posts: 189
Joined: Sun Sep 15, 2013 9:44 pm

CS:S rates revert to 66

Post by doulos9 » Fri Sep 12, 2014 12:12 am

This is from the server.cfg file:
sv_maxupdaterate 99
sv_maxcmdrate 99
sv_maxrate 0
sv_minrate 100000

This is from my config.cfg file:
cl_cmdrate "99"
cl_updaterate "99"


Why do I get different values when I type those commands in my game console (i.e. "cl_updaterate" = "66, and "cl_cmdrate" "66")? Nowhere else do I set those rates. If I change them in game console to 99 they stay that way until a map change then revert back to 66.

I have searched for an answer to this but cannot seem to find one.

Thanks,
Chuck

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: CS:S rates revert to 66

Post by soja » Fri Sep 12, 2014 1:47 am

Sounds like your server is still 66 tick. Have you installed tickrate enabler?
Not a NFO employee

doulos9
This is my homepage
This is my homepage
Posts: 189
Joined: Sun Sep 15, 2013 9:44 pm

Re: CS:S rates revert to 66

Post by doulos9 » Fri Sep 12, 2014 10:22 pm

Yes, it is still 66-tick. Didn't even know it was possible to run it at 100-tick, but not sure if I should. It is a 40-slot CS:S server full most every night. I don't know if the box can handle 100-tick with 40 players.
Your server is currently being hosted on a Intel Xeon X3360 (Yorkfield 2.83ghz) node with 4 total processor cores and 8 gigabytes of RAM. The database code for this node is denver-quad283; its OS is Windows.
Who knows how many other games are on that box.

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: CS:S rates revert to 66

Post by soja » Fri Sep 12, 2014 11:13 pm

You shouldn't run 100 tick on a 40 slot server. I mentioned the enabler since it seems you thought you should be getting 99-100 updates.

Your rates will not go over 66 because the server is 66 tick.
Not a NFO employee

User avatar
kraze
Staff
Staff
Posts: 4357
Joined: Fri Sep 17, 2010 9:06 am
Location: California

Re: CS:S rates revert to 66

Post by kraze » Sat Sep 13, 2014 12:07 am

doulos9 wrote:Yes, it is still 66-tick. Didn't even know it was possible to run it at 100-tick, but not sure if I should. It is a 40-slot CS:S server full most every night. I don't know if the box can handle 100-tick with 40 players.
Your server is currently being hosted on a Intel Xeon X3360 (Yorkfield 2.83ghz) node with 4 total processor cores and 8 gigabytes of RAM. The database code for this node is denver-quad283; its OS is Windows.
Who knows how many other games are on that box.

It's not about how many other servers are on the box. Overall load would be one of the biggest factor here. In your case, your machine peaked at 25% CPU usage with 59 players total. If your number of 40 is accurate, it basically means it you and 1-2 other people on the entire box.

As for 100 tick. I wouldn't recommend it. CS:S can be a bit piggy at higher player counts, and increasing the tickrate will only increase that usage. Though, you are more than welcome to try it. No real harm in doing so.
@Kraze^NFo> Juski has a very valid point
@Juski> Got my new signature, thanks!
@Kraze^NFo> Out of context!
@Juski> Doesn't matter!
@Juski> You said I had a valid point! You can't take it back now! It's out there!

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: CS:S rates revert to 66

Post by soja » Sat Sep 13, 2014 12:47 am

He would need to be placed on a faster box to try 100 tick. I also do not recommend it, but a 100-tick 40 slot server uses easily over a core of an E3-1270(I have a 40 slot 100-tick CS:S server on managed).
Not a NFO employee

doulos9
This is my homepage
This is my homepage
Posts: 189
Joined: Sun Sep 15, 2013 9:44 pm

Re: CS:S rates revert to 66

Post by doulos9 » Sat Sep 13, 2014 8:26 am

We tried 100-tick at another GSP and it did not go well at all. Never considered it here either. I just wondered about the rates since the initial NFO setup had 99 for each of the sv_ rates mentioned above.

I always check the cpu and ram whenever someone complains about the "server lagging" (even though I don't see it myself, though I do see individuals lagging - usually high latency is the cause IMO). The cpu and ram are always well within acceptable ranges. Cudo's NFO. I don't see how you can make money with only 2-3 servers on that box, but I sure do appreciate it.

Thanks for the info.

Post Reply