L4D2 Versus Mode - Server shutting down

Post Reply
DogByte
New to forums
New to forums
Posts: 2
Joined: Sun Nov 11, 2012 1:36 pm

L4D2 Versus Mode - Server shutting down

Post by DogByte » Sun Nov 11, 2012 1:45 pm

Hi,

I'm trying to allow one player to play against the "bots" on my L4D2 versus server. The problem I am having is that the server requires players on both teams during competitive play and shuts down when there is only one player. I also do not want to enable cheats (sv_cheats 1) so I researched this and read that setting "sm_cvar sb_all_bot_team 1" in server.cfg should allow a player to play on the server alone.

However, after restarting the server with the new server.cfg file, the server still shuts down when there is only one player on it.

NFO tech support suggested I ask here for a solution. Any help?

Thanks,

DogByte

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: L4D2 Versus Mode - Server shutting down

Post by soja » Sun Nov 11, 2012 7:23 pm

Found a youtube vid that said after an update in 2010,

instead of sb_bot_all_team 1;
instead use sb_all_bot_game 1.


Let me know if it doesn't work, I'll try to find more :)
Not a NFO employee

DogByte
New to forums
New to forums
Posts: 2
Joined: Sun Nov 11, 2012 1:36 pm

Re: L4D2 Versus Mode - Server shutting down

Post by DogByte » Tue Nov 13, 2012 6:23 pm

Hi,

Thanks for the info, but when using "sb_all_bot_game 1" in server.cfg, the server still shuts down.

I have sourcemod installed and using "sm_cvar sb_all_bot_game 1" allows the server to keep running but brings up a new problem. The game runs fine when I am a survivor, but when I'm infected, the survivor "bots" won't leave the spawn area and I can't spawn in to attack them because they haven't left the spawn area. I think it's because they are waiting to follow a player and there isn't one to follow.

DogByte

User avatar
Edge100x
Founder
Founder
Posts: 12219
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: L4D2 Versus Mode - Server shutting down

Post by Edge100x » Tue Nov 13, 2012 11:46 pm

This plugin and its "sm_unfreezebots" command might be worth a try: http://forums.alliedmods.net/showthread.php?t=126940.

Post Reply