ReHLDS Won't Start Up / Appear In-Game

Post Reply
ZEDD_Intensity
New to forums
New to forums
Posts: 2
Joined: Sun Feb 26, 2017 9:23 pm

ReHLDS Won't Start Up / Appear In-Game

Post by ZEDD_Intensity » Thu May 03, 2018 3:43 am

Greetings NuclearFallout,

I'm aware and respect that you can't help with very server-specific requests as this can be a bit of that, but if you can do anything to contribute some checklists or any help with the problem, It'd be greatly appreciated whatever it is.

It's quite a weird problem . Myself, being a developer, I'm quite sure I've pretty much done everything I could've, to get my ReHLDS v3.3.0.643 running with Metamod -P v1.21p38 with ReAMXX 1.8.3-dev and ReGameDLL v5.3.0.280-dev. Basically, it's a modified HLDS that won't run even with SELinux Disabled. Server console showing activity as it running custom plugins whereas it doesn't show up at all in RCON, nor in-game. I'm here to get some advice other experts if I've missed something. The server won't start with Official HLDS from Steam, and nor Reverse-Engineered HLDS at all. Confirmed that the problem isn't with steamcmd or app manifests. Tested that even with AMXX, MM and Default ReGameDLL (meaning, an absolutely clean installation), the server still WON'T start.

I've made a very brief post over at https://forums.alliedmods.net/showthread.php?t=307239 including debug logs and stuff. It's a huge post and updates in my replies, so I thought copy pasting all of it here wouldn't be the best idea. I appreciate if you just read it through for every other details needed to help troubleshoot the problem.

Hope I didn't miss mentioning anything here. Appreciate literally any help at all.

Thanks and Kindest Regards,
ZEDD

Edit : The server is only a "Test Server" and will not be accepting any audience as players. Just thought I'd clarify.

ZEDD_Intensity
New to forums
New to forums
Posts: 2
Joined: Sun Feb 26, 2017 9:23 pm

Re: ReHLDS Won't Start Up / Appear In-Game

Post by ZEDD_Intensity » Sat May 05, 2018 12:55 pm

Hi there,

Sorry for bumping this thread as I couldn't find an edit button.

This is just to update that, The problem has been solved.
The solution is still unknown as the 3-days untouched server went online absolutely randomly without running any Starting parameters. So, the unknown problem should be considered as some problem with Steam Servers.

Thread over at AlliedMods has been updated at https://forums.alliedmods.net/showpost. ... stcount=13.

Thanks to all the 18 humans who have viewed this thread. Thanks for reading.

Kind Regards,
ZEDD

User avatar
hiimcody1
Staff
Staff
Posts: 1277
Joined: Wed Dec 28, 2011 4:59 pm

Re: ReHLDS Won't Start Up / Appear In-Game

Post by hiimcody1 » Sat May 05, 2018 1:25 pm

I'm glad that it started working for you, though that is a puzzling thing to have happen.

Steam has done stranger things though I suppose.

Post Reply