FastDL Isn't Working Anymore?

Post Reply
Wrath
A semi-regular
A semi-regular
Posts: 22
Joined: Sun May 18, 2014 12:07 pm

FastDL Isn't Working Anymore?

Post by Wrath » Wed Jun 25, 2014 4:37 pm

Okay, I've had my server for over a month now, and FastDL has worked fine. However, just a few hours ago, something began to not work properly. According to my players, quite a few models that they had previously been able to see in the PointShop are now errors. Many of the files are not downloading despite them being in the FastDL server file as they always have been. I checked through the FastDL lua file to see if there was a problem, and I had found one, the quotes around the numbers weren't closed, so I fixed that. My players were then able to see more of the models, but still not all of them. Below is what is placed in the FastDL lua, so if someone notices anything off, please tell me:

Code: Select all

// Defibrillator \\
resource.AddWorkshop( "162581348" )

// Orbital Bass Cannon \\
resource.AddWorkshop( "252189849" )

// Grappling Hook \\
resource.AddWorkshop( "265714452" )

// Poison Gun \\
resource.AddWorkshop( "237552183" )

// Golden Gun \\
resource.AddWorkshop( "233067112" )

// Head Crab Launcher \\
resource.AddWorkshop( "258844685" )

// Sentry Gun \\
resource.AddWorkshop( "191465597" )

// TTT Punisher SWEP \\
resource.AddWorkshop( "214216113" )

// Pain Pills \\
resource.AddWorkshop( "218687503" )

// Manhack Spawner \\
resource.AddWorkshop( "233967112" )

// Adminstick \\
resource.AddWorkshop( "125628460" )


// Chat Tags \\
resource.AddWorkshop( "272591265" )


// Atlas Player Model \\
resource.AddWorkshop( "219267230" )

// Shrek Player Model \\
resource.AddWorkshop( "161999160" )

// Osama Bin Laden Player Model \\
resource.AddWorkshop( "175002964" )

// Daft Punk Player Model \\
resource.AddWorkshop( "148628139" )

// Dixon Brothers Player Model \\
resource.AddWorkshop( "141889780" )

// Zack Halloween Player Model \\
resource.AddWorkshop( "242707219" )

// Spiderman Player Models \\
resource.AddWorkshop( "172303156" )

// Hitler Player Model \\
resource.AddWorkshop( "116797740" )

// Connor Kenway Player Model \\
resource.AddWorkshop( "132503878" )

// Walter White Player Model \\
resource.AddWorkshop( "227312918" )

// Deadpool Player Model \\
resource.AddWorkshop( "200700693" )

// Edward Kenway Player Model \\
resource.AddWorkshop( "238213159" )

// Husk Player Model \\
resource.AddWorkshop( "153107823" )

// Gmod Tower Player Models \\
resource.AddWorkshop( "150404359" )

// Barack Obama Player Model \\
resource.AddWorkshop( "238855334" )

// Ezio Player Model \\
resource.AddWorkshop( "237984526" )

// Coco Pommel Player Model \\
resource.AddWorkshop( "249671846" )

// Lollipop Chainsaw Player Models \\
resource.AddWorkshop( "107308312" )

// Jesus Player Model \\
resource.AddWorkshop( "237872885" )

// TRON Anon Player Model \\
resource.AddWorkshop( "241187700" )

// Eeveelution Player Models \\
resource.AddWorkshop( "252519802" )

// Master Chief Player Model \\
resource.AddWorkshop( "254109010" )

// FMA Player Models \\
resource.AddWorkshop( "263181057" )

// Lucario Player Model \\
resource.AddWorkshop( "118650502" )
=======================

Also, another thing. Yesterday I added an addon from the Garry's Mod Steam Workshop, and it worked perfectly fine. However, I decided that I wanted to delete it because I personally didn't like it. I went into my FileZilla client and deleted the folder that was placed in addons and removed it from the FastDL. However, the item still appears in the Traitor menu (it was a T item). Any idea on how to get rid of this?

Thanks for any help for both questions!

User avatar
kraze
Staff
Staff
Posts: 4359
Joined: Fri Sep 17, 2010 9:06 am
Location: California

Re: FastDL Isn't Working Anymore?

Post by kraze » Thu Jun 26, 2014 3:28 pm

Your fastdl file appears to be correct. Just to be sure I'd double check that the models are still on the server and in the correct directories. I'd also enable -condebug via the "server control" tab in your control panel so you can view your console.log file. This file will detail if some of the workshop content is failing to download.
lso, another thing. Yesterday I added an addon from the Garry's Mod Steam Workshop, and it worked perfectly fine. However, I decided that I wanted to delete it because I personally didn't like it. I went into my FileZilla client and deleted the folder that was placed in addons and removed it from the FastDL. However, the item still appears in the Traitor menu (it was a T item). Any idea on how to get rid of this?
DId you actually remove it from the workshop collection? If not, it's just going to re-download upon server boot.
@Kraze^NFo> Juski has a very valid point
@Juski> Got my new signature, thanks!
@Kraze^NFo> Out of context!
@Juski> Doesn't matter!
@Juski> You said I had a valid point! You can't take it back now! It's out there!

User avatar
Decicus
Compulsive poster
Compulsive poster
Posts: 63
Joined: Thu Dec 05, 2013 1:55 am
Location: Norway
Contact:

Re: FastDL Isn't Working Anymore?

Post by Decicus » Thu Jun 26, 2014 6:09 pm

Correct me if I'm wrong, but I thought Workshop items downloaded from the workshop and didn't require FastDL?

joshh20
This is my homepage
This is my homepage
Posts: 146
Joined: Sat Mar 02, 2013 1:35 pm

Re: FastDL Isn't Working Anymore?

Post by joshh20 » Thu Jun 26, 2014 7:48 pm

You are correct, but except for maps, you will still need to include a resource.AddWorkship for the client to download them.

Wrath
A semi-regular
A semi-regular
Posts: 22
Joined: Sun May 18, 2014 12:07 pm

Re: FastDL Isn't Working Anymore?

Post by Wrath » Fri Jun 27, 2014 10:15 pm

kraze wrote:Your fastdl file appears to be correct. Just to be sure I'd double check that the models are still on the server and in the correct directories. I'd also enable -condebug via the "server control" tab in your control panel so you can view your console.log file. This file will detail if some of the workshop content is failing to download.
lso, another thing. Yesterday I added an addon from the Garry's Mod Steam Workshop, and it worked perfectly fine. However, I decided that I wanted to delete it because I personally didn't like it. I went into my FileZilla client and deleted the folder that was placed in addons and removed it from the FastDL. However, the item still appears in the Traitor menu (it was a T item). Any idea on how to get rid of this?
Did you actually remove it from the workshop collection? If not, it's just going to re-download upon server boot.
Thanks for the help! I'm not sure how, but the FastDL problem seemed to fix itself on its own. Not sure how, but whatever. xD

Also, I deleted the file from the collection and it was fine. Completely forgot to do that the first time I tried. xD

Thanks!

Post Reply