VDS Gmod Server software CPU usage stalling.

Post Reply
Amu
New to forums
New to forums
Posts: 1
Joined: Sun Aug 05, 2018 4:28 pm

VDS Gmod Server software CPU usage stalling.

Post by Amu » Sun Aug 05, 2018 4:51 pm

I'm running a Garry's Mod Server on a Linux VDS. The server is experiencing cpu usage stalls going from it's normal percent down to sub 1%. When this happens everything in the game comes to a halt and players may or may not disconnect. It doesn't seem to matter how many people are on when it happens. (It has happened right as I have spawned in by myself) It can happen over and over, or be calm for long periods of time. It seems to happen at random. When the problem occurs, no errors are presented. I don't know if it's Ddos or software related.

This started around the first of the month and since then I've tried removing all recent addons etc, to no avail. This happened around the same time I implemented a new map with a cinema gamemode lua, however, after reverting back to older maps the problem still persists.

Collection I'm using: https://steamcommunity.com/sharedfiles/ ... 1434888250
Addons: https://puu.sh/B9lEv/d717b85948.png

I'm confused as the server was fine, the only thing I had recently changed when we started seeing this problem was the addition of some models/map. I've removed them etc and still the problem persisted. I tried removing pointshop 2 as well to see if it was a database issue.. I haven't messed with prometheus since I set it up, but it was working for a good week before this started.

Post Reply