My server seems to refuse the websync. (Lua Cache)

Post Reply
Charrax
New to forums
New to forums
Posts: 8
Joined: Mon Mar 12, 2012 2:58 am

My server seems to refuse the websync. (Lua Cache)

Post by Charrax » Mon Mar 12, 2012 3:02 am

Even after performing a websync. The server still has the infamous Lua cache error.

I have tried restarting the server and all... Also after doing this, sometimes the server seems it is working fine... But the error persists.

Any ideas?

User avatar
Edge100x
Founder
Founder
Posts: 12235
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: My server seems to refuse the websync. (Lua Cache)

Post by Edge100x » Mon Mar 12, 2012 11:34 am

Is the websync copying over files when it runs?

Charrax
New to forums
New to forums
Posts: 8
Joined: Mon Mar 12, 2012 2:58 am

Re: My server seems to refuse the websync. (Lua Cache)

Post by Charrax » Mon Mar 12, 2012 1:21 pm

Edge100x wrote:Is the websync copying over files when it runs?
I imagine it should...

User avatar
TimeX
Staff
Staff
Posts: 1390
Joined: Thu Jul 22, 2004 12:24 am
Location: Big Bear, CA

Re: My server seems to refuse the websync. (Lua Cache)

Post by TimeX » Mon Mar 12, 2012 1:26 pm

The "Events log" page will say which files are copied over in the process. Using that information, check to see if the cache file is listed. If it is, see if the file is actually on the web hosting.
TimeX

Charrax
New to forums
New to forums
Posts: 8
Joined: Mon Mar 12, 2012 2:58 am

Re: My server seems to refuse the websync. (Lua Cache)

Post by Charrax » Mon Mar 12, 2012 1:35 pm

I dont see how I can check which files are copied over. each time it says 499.

EDIT: also here is the line(s): Lua cache file "cache/4b5717f4ff98042845bc436c46e8de3a.dua" does not exist. This indicates a server misconfiguration. Most likely fastdl is enabled, but the server host hasn't mirrored the pack.


But over yonder server it is there: ftp://xenogm002.game.nfoservers.com/garrysmod/cache/

Just did another websync.

Charrax
New to forums
New to forums
Posts: 8
Joined: Mon Mar 12, 2012 2:58 am

Re: My server seems to refuse the websync. (Lua Cache)

Post by Charrax » Mon Mar 12, 2012 1:42 pm

Since I cannot edit, might aswell say that this time the files has decreased form 499 to 360.

User avatar
TimeX
Staff
Staff
Posts: 1390
Joined: Thu Jul 22, 2004 12:24 am
Location: Big Bear, CA

Re: My server seems to refuse the websync. (Lua Cache)

Post by TimeX » Mon Mar 12, 2012 2:10 pm

Is the cache file itself on the web hosting? If not, then it sounds like the problem is just the files failing to copy over properly, which we would need to look at.
TimeX

Axtown
New to forums
New to forums
Posts: 9
Joined: Tue May 01, 2012 6:03 am

Re: My server seems to refuse the websync. (Lua Cache)

Post by Axtown » Wed May 02, 2012 1:14 pm

I had the exact problem... Just get a Staff to run a repair...
It probably had deleted some of the Files that were already on there since the beginning.
That would help...

Post Reply