A strange occurance on my server (semi-important)

Post Reply
matrixninja
New to forums
New to forums
Posts: 7
Joined: Sun Apr 29, 2012 4:25 pm

A strange occurance on my server (semi-important)

Post by matrixninja » Sun May 06, 2012 8:26 am

A user entered my gmod server, and a few minutes after joining said: "Enjoy the blur n******", and every user, including mine, had a blurry screen. To describe it at best, the players FOV was blurry, except for the immediate space around them, so if they looked up, everything was blurry. I immediately banned the player, but it did not go away. I removed his props, it still did not go away. I was forced to restart the server, as it was causing tremendous lag. Google was no help, as apparently this never happened. My question is, do you have any insight on how this happens, and how to stop and/or prevent it? Thanks!

Kropp
A regular
A regular
Posts: 48
Joined: Mon Apr 02, 2012 1:10 pm
Location: Canada, British Columbia
Contact:

Re: A strange occurance on my server (semi-important)

Post by Kropp » Sun May 06, 2012 10:37 am

I believe this will fix it.
add this to autocexec.cfg

if CLIENT then concommand.Remove( "pp_pixelrender" ) end
Image

matrixninja
New to forums
New to forums
Posts: 7
Joined: Sun Apr 29, 2012 4:25 pm

Re: A strange occurance on my server (semi-important)

Post by matrixninja » Sun May 06, 2012 2:52 pm

What does that bit of code do exactly?

Kropp
A regular
A regular
Posts: 48
Joined: Mon Apr 02, 2012 1:10 pm
Location: Canada, British Columbia
Contact:

Re: A strange occurance on my server (semi-important)

Post by Kropp » Sun May 06, 2012 3:21 pm

It stops a client from running a command that blurs every one's vision making it extremely laggy.
Image

TheLastPenguin
A semi-regular
A semi-regular
Posts: 25
Joined: Tue Aug 28, 2012 4:33 pm

Re: A strange occurance on my server (semi-important)

Post by TheLastPenguin » Tue Aug 28, 2012 4:40 pm

1) Kropp's fix won't even work if it's added to the auto exec.cfg
2) it should go in Lua/autorun/server/pprenderblock.lua ( you must make the directory )
3) I'm pretty sure it's not the cause of the problem.

I have heard of a turret effect glitch that causes something like what you described. That may be your issue. To fix it just block turrets. If its not that someone may have found another way to use the martial based exploit or a similar exploit. If that's the case it's unlikely you will be able to find any info on it.

Post Reply