Something in SourceMod causing crash on startup

Post Reply
ashm0re
New to forums
New to forums
Posts: 2
Joined: Sun Feb 22, 2015 4:41 pm

Something in SourceMod causing crash on startup

Post by ashm0re » Sun Feb 22, 2015 4:51 pm

Recently, out of nowhere, my server just stopped working. I haven't really been able to narrow down EXACTLY what's causing it, but I do know that it's something within sourcemod. Last time it happened, was right before the newest CS:GO update and as soon as CSGO updated, my server started working again without me changing anything but as of yesterday, it has stopped working again. Support says it's crashing on startup, and will only start up when I disable sourcemod all together. I know there is a new version of sourcemod out now and was wondering if that might fix my issue? Or is it more than likely something related to one of the plugins I'm running? I was given this server as is a few months ago and have never had to edit any plugins as everything has always ran smoothly until now so I'm a bit new when it comes to narrowing down the exact cause of the crash. If someone with the patience to explain it like I'm 5 would be willing to help, I would really appreciate it.

User avatar
kraze
Staff
Staff
Posts: 4359
Joined: Fri Sep 17, 2010 9:06 am
Location: California

Re: Something in SourceMod causing crash on startup

Post by kraze » Sun Feb 22, 2015 11:20 pm

It seems like the easiest thing to do at this point would be to update SM and see if that fixes the issue.
@Kraze^NFo> Juski has a very valid point
@Juski> Got my new signature, thanks!
@Kraze^NFo> Out of context!
@Juski> Doesn't matter!
@Juski> You said I had a valid point! You can't take it back now! It's out there!

ashm0re
New to forums
New to forums
Posts: 2
Joined: Sun Feb 22, 2015 4:41 pm

Re: Something in SourceMod causing crash on startup

Post by ashm0re » Mon Feb 23, 2015 9:13 pm

kraze wrote:It seems like the easiest thing to do at this point would be to update SM and see if that fixes the issue.

Well since posting this, I had a friend help mine troubleshoot some things and teach me a little bit. I ended up narrowing it down to a specific plugin related to my surf timer. Unfortunately, that just leaves me with even more questions because I'm not sure what could cause a working plugin to just simply fail out of nowhere. I tried recompiling the plugin, but it still causes my server to crash and I replaced it with a newer version but that left me with incompatibility issues with my plugins and my database. (everything worked but all of my servers records were missing, but everything else related to the database works) I'm not sure where to go from here at all, hopefully I can figure it out before it's too late.

User avatar
kraze
Staff
Staff
Posts: 4359
Joined: Fri Sep 17, 2010 9:06 am
Location: California

Re: Something in SourceMod causing crash on startup

Post by kraze » Mon Feb 23, 2015 10:14 pm

That is actually more common then you think. Happens all the time as updates are released and things on the back end change. It's ultimately up to the plugin developer to address the those problems and put out a patch.
@Kraze^NFo> Juski has a very valid point
@Juski> Got my new signature, thanks!
@Kraze^NFo> Out of context!
@Juski> Doesn't matter!
@Juski> You said I had a valid point! You can't take it back now! It's out there!

Post Reply