Can't make changes to gamemode_competitive_server.cfg

Post Reply
xShabutie
New to forums
New to forums
Posts: 2
Joined: Fri Sep 04, 2015 4:16 am

Can't make changes to gamemode_competitive_server.cfg

Post by xShabutie » Fri Sep 04, 2015 4:20 am

Hey there,

I've been trying to add bot_quota 0 to my gamemode_competitive_server.cfg file; however, any time I add it to that file and restart the server, I can no longer spawn.

The only way to fix this is by executing another config file (1v1.cfg for instance).

Once I remove bot_quota 0 from gamemode_competitive_server.cfg and restart the server, I can spawn without a problem (along with 9 bots...)

I'm not sure what I might be doing wrong?

Thanks.

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't make changes to gamemode_competitive_server.cfg

Post by Markie » Fri Sep 04, 2015 4:32 am

I believe to do this, the file you want to edit is gamemode_competitive.cfg

Code: Select all

bot_chatter off
bot_quota 0
bot_quota_mode normal

xShabutie
New to forums
New to forums
Posts: 2
Joined: Fri Sep 04, 2015 4:16 am

Re: Can't make changes to gamemode_competitive_server.cfg

Post by xShabutie » Fri Sep 04, 2015 5:36 am

I've read that we should be making changes in the _server file because the other one gets overwritten on server updates.

The main issue seems to be with bot_quota 0.

When using the mapchooser plugin, if I add bot_quota 0 to any of my map-cfg files, I can't spawn.

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: Can't make changes to gamemode_competitive_server.cfg

Post by soja » Fri Sep 04, 2015 9:06 am

xShabutie wrote:I've read that we should be making changes in the _server file because the other one gets overwritten on server updates.

The main issue seems to be with bot_quota 0.

When using the mapchooser plugin, if I add bot_quota 0 to any of my map-cfg files, I can't spawn.
If you are running a managed/unmanaged service, try adding -nobots to your command line.
Not a NFO employee

TroyMLP
New to forums
New to forums
Posts: 6
Joined: Wed Apr 30, 2014 7:10 am

Re: Can't make changes to gamemode_competitive_server.cfg

Post by TroyMLP » Thu Mar 03, 2016 5:35 pm

soja wrote:
xShabutie wrote:I've read that we should be making changes in the _server file because the other one gets overwritten on server updates.

The main issue seems to be with bot_quota 0.

When using the mapchooser plugin, if I add bot_quota 0 to any of my map-cfg files, I can't spawn.
If you are running a managed/unmanaged service, try adding -nobots to your command line.
Alternatively you can create a config with specific settings you want to use for competitive and exec that alongside your gamemodes_competitive_server, there is a spot in gamemodes_server to add other configs to exec. I say this because -nobots will also not permit gotv which emulates a bot.

Post Reply