Conflicting Mods

Post Reply
Soloo
New to forums
New to forums
Posts: 4
Joined: Sun Jul 15, 2018 3:45 pm

Conflicting Mods

Post by Soloo » Sun Jul 15, 2018 3:48 pm

I'm sure there is a simple answer to this but I've been pulling hairs so any help would be appreciated.

This is the bottom of my rpt:

Code: Select all

19:42:56 Conflicting addon TRYK_Uniform in 'zara\', previous definition in 'tryk_unit\'
19:42:56 Conflicting addon OPTRE_FC_Weapons_PlasmaRifle in 'OPTRE_FC_Weapons\plasmarifle\', previous definition in 'OPTRE_FC_Weapons\fuelrod\'
19:42:56 Conflicting addon OPTRE_FC_Weapons_PlasmaRifle in 'OPTRE_FC_Weapons\plasmapistol\', previous definition in 'OPTRE_FC_Weapons\fuelrod\'
19:42:56 Conflicting addon OPTRE_UNSC_Structure_Military in 'OPTRE_Buildings\military\', previous definition in 'OPTRE_Arctic\'
19:42:57 Conflicting addon Desert in 'ca\desert_c\', previous definition in 'music\'
19:43:00 Warning Message: Addon 'SMA_RHS_Patch' requires addon 'rhsusf_weapons'
I have tried to:
- Reinstall the addons.
- Rename the addons to remove symbols [ _ ( , ]
- Given the server 30+ minutes to start on its own.

Soloo
New to forums
New to forums
Posts: 4
Joined: Sun Jul 15, 2018 3:45 pm

Re: Conflicting Mods

Post by Soloo » Sun Jul 15, 2018 6:55 pm

- Confirmed no dependencies missing.

Caliban55
This is my homepage
This is my homepage
Posts: 436
Joined: Sat Sep 04, 2010 10:20 am
Location: Cologne, Gemany
Contact:

Re: Conflicting Mods

Post by Caliban55 » Mon Jul 16, 2018 3:08 am

Please post a complete RPT, plus the starting command line with all the mods you want to load.

As to the info posted, the last line states that SMA_RHS_Patch requires rhsusf_weapons. If the server can't find that mod, it wasn't loaded successfully (hence the request for the full RPT).

The conflicting mods may be due to overlapping configs, your only solution is to avoid these mod combinations. Start the server with loading one mod at a time until you reach a stable server init stage.

Renaming an addon and removing characters is not required and not recommended and may break a mod, if there are coded dependencies within the mod.

Post Reply