Black Screens - Server Issue?

Post Reply
User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Black Screens - Server Issue?

Post by TimSad » Mon Oct 22, 2012 9:15 pm

I think that I have found the reason why so many people on the Battlelog forums are getting this Black Screen problem when getting into game. I noticed that when I set our server to the "Warfighter" playlist (which contains a set list of TDM and Sector Control maps), Battlelog displayed "Unknown" in the part of the server description where it would typically show the game mode. So, joining the server like that, everyone was getting a black screen but when I restarted the server with just the "Sector Control" playlist (which now displays as "Sector Control" rather than "Unknown"), I was able to play - with no black screen.
                                                Our NFO Battlefield Servers!
ImageImage
Image

User avatar
kraze
Staff
Staff
Posts: 4357
Joined: Fri Sep 17, 2010 9:06 am
Location: California

Re: Black Screens - Server Issue?

Post by kraze » Mon Oct 22, 2012 9:21 pm

We were able to confirm that TDM is indeed broken in the release. We are in the process of removing that option that defaulting all servers to another gametype.
@Kraze^NFo> Juski has a very valid point
@Juski> Got my new signature, thanks!
@Kraze^NFo> Out of context!
@Juski> Doesn't matter!
@Juski> You said I had a valid point! You can't take it back now! It's out there!

User avatar
Edge100x
Founder
Founder
Posts: 12219
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Black Screens - Server Issue?

Post by Edge100x » Mon Oct 22, 2012 10:13 pm

After further testing, I found that the server sometimes doesn't work and sometimes does, regardless of the playlist option chosen (sometimes Warfighter works and sometimes it doesn't, sometimes TDM works and sometimes it doesn't, for instance). This indicates that the problem is likely with Blaze or the client. But, I'm continuing to experiment.

Zoo
New to forums
New to forums
Posts: 1
Joined: Mon Oct 22, 2012 11:59 pm

Re: Black Screens - Server Issue?

Post by Zoo » Tue Oct 23, 2012 12:07 am

I was able to get our server working. I had originally had it set to "All Sector Control". I switched it to Custom, tried to put in the maps/modes manually and then submitted changes. I got an error so I put it back to All Sector Control and it worked. Also, where it had said "Unknown" under the server name in the server browser of BattleLog, it changed to Sector Control. Hope this helps.

User avatar
soja
This is my homepage
This is my homepage
Posts: 2389
Joined: Fri May 18, 2012 3:20 pm

Re: Black Screens - Server Issue?

Post by soja » Wed Oct 24, 2012 7:17 am

I have also found that if the game type is listed as unknown I get the black screen at loading, something to help troubleshoot I guess
Not a NFO employee

Post Reply