Server Connecting Problems

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Server Connecting Problems

Post by TimSad » Fri Nov 29, 2013 1:40 am

Recently everyone has been having problems connecting to our Battlefield 4 servers. Players are getting stuck at "Connecting" then if they let it sit for a while it'll eventually give them the error "Game disconnected: could not join server." Eventually it'll let them get past the "Connecting" state and finally load them in if they keep trying but I'm still unsure of when or why it will finally let them in.

I can't really find any trend as to when or why it doesn't let players connect like this but if I could hazard a guess I would say that it has something to do with maybe recently leaving one server then trying to join another of ours. But if they attempt to join several times, it'll finally let them through.

Is anyone else seeing this with their servers?
                                                Our NFO Battlefield Servers!
ImageImage
Image

User avatar
Edge100x
Founder
Founder
Posts: 12285
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Server Connecting Problems

Post by Edge100x » Fri Nov 29, 2013 2:19 am

In the last 20 minutes, Blaze had a global downtime event of some sort, which led to most players dropping from servers. It's possible that EA/DICE is troubleshooting problems with it currently (the timeframe fits for that). This could also be a follow-up to the long Battlelog maintenance last night.

It's annoying to have problems and maintenance on a holiday weekend like this, when more people are playing, and playing longer into the night.

User avatar
FourTwoFour
This is my homepage
This is my homepage
Posts: 98
Joined: Fri Dec 16, 2011 3:47 am

Re: Server Connecting Problems

Post by FourTwoFour » Fri Nov 29, 2013 7:18 am

Happens to me every time I get kicked for idle and then try to rejoin. Could not join server only gets fixed after the map changes (for me). Very annoying.
Image

[WDT]TardFarmer
This is my homepage
This is my homepage
Posts: 106
Joined: Tue Nov 05, 2013 7:01 am

Re: Server Connecting Problems

Post by [WDT]TardFarmer » Fri Nov 29, 2013 8:12 am

had a lot of complaints from players saying they could not get in last night. They said they went to other servers and they were able to login fine. One opened a case with EA who told them to talk to the server admins as we must be blocking them.... they must have forgotten that we run an official server and have no control. (I did check the firewall for his IP)

wihgaming
This is my homepage
This is my homepage
Posts: 174
Joined: Mon Oct 28, 2013 7:10 am

Re: Server Connecting Problems

Post by wihgaming » Fri Nov 29, 2013 9:04 am

I've experienced this same problem on my own server. Some of our members also experienced the same thing too. Seems to be intermittent, but from our experience it happens after our server have been running for 16-18 hours, with a queue of 3-5 people. When the server is not full, we've not seen thsi problem.

ADKGamers
This is my homepage
This is my homepage
Posts: 90
Joined: Mon Oct 28, 2013 4:19 pm

Re: Server Connecting Problems

Post by ADKGamers » Fri Nov 29, 2013 4:55 pm

Having this issue on one of my servers right now, a lot of people are complaining but it's still full -_-
http://www.ADKGamers.com - =ADK= Multi Gaming Community

User avatar
Edge100x
Founder
Founder
Posts: 12285
Joined: Thu Apr 18, 2002 11:04 pm
Location: Seattle
Contact:

Re: Server Connecting Problems

Post by Edge100x » Fri Nov 29, 2013 11:40 pm

If this is happening on full servers, it could also be related to the queuing issue we've seen lately, in which the first person to enter the queue ends up waiting forever to get in under certain circumstances.

Other RSPs have confirmed the same problem and DICE knows about it. I hope it's taken care of in the next update to Battlelog.

User avatar
GaWebDevDotCom
A regular
A regular
Posts: 46
Joined: Mon Nov 05, 2012 1:07 pm
Location: Milan, Georgia
Contact:

Re: Server Connecting Problems

Post by GaWebDevDotCom » Sat Nov 30, 2013 10:07 pm

Seems to only be impacting the one server I have on VPS. The other two standalones never have the issue only the one on VPS. It stays pretty full (so when it does not crash and I don't do a restart once every 2 days minimum) the issue reappears.

Restart always clears the issue. Odd.

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Re: Server Connecting Problems

Post by TimSad » Sun Dec 01, 2013 6:10 pm

Just saw this thread on my forums. Haven't had the time to post to it yet but thought I'd share it here... http://soldiersofchaosgaming.com/forum/ ... =38&t=1629
                                                Our NFO Battlefield Servers!
ImageImage
Image

wihgaming
This is my homepage
This is my homepage
Posts: 174
Joined: Mon Oct 28, 2013 7:10 am

Re: Server Connecting Problems

Post by wihgaming » Sun Dec 01, 2013 8:28 pm

My server was doing this a lot tonite. I had to reboot the server to get rid of this problem. I'm sure it'll rear its ugly head again in the middle of the nite...

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Re: Server Connecting Problems

Post by TimSad » Mon Jan 06, 2014 10:07 pm

It's been happening more again lately. It seems that after you try the first time, you can wait for the round to end and after it's done loading the next map you can successfully get into the server.
                                                Our NFO Battlefield Servers!
ImageImage
Image

[WDT]TardFarmer
This is my homepage
This is my homepage
Posts: 106
Joined: Tue Nov 05, 2013 7:01 am

Re: Server Connecting Problems

Post by [WDT]TardFarmer » Tue Jan 07, 2014 9:39 am

TimSad wrote:It's been happening more again lately. It seems that after you try the first time, you can wait for the round to end and after it's done loading the next map you can successfully get into the server.

Having the exact same issue, Rebooting the server has not seemed to help. This just started up again. It had gone away for about a month

User avatar
TimSad
This is my homepage
This is my homepage
Posts: 754
Joined: Thu Jun 30, 2011 6:27 pm

Re: Server Connecting Problems

Post by TimSad » Sat Jan 18, 2014 8:37 pm

It's still happening! It's worse off on our TDM server!
                                                Our NFO Battlefield Servers!
ImageImage
Image

wihgaming
This is my homepage
This is my homepage
Posts: 174
Joined: Mon Oct 28, 2013 7:10 am

Re: Server Connecting Problems

Post by wihgaming » Sat Jan 18, 2014 9:16 pm

I noticed that my control panel, procon, and battlelog all are reporting the same player count. Even though it is showing 60/64, it won't let any new players join.

With R17, my server would exhibit this problem (a little different where BattleLog thinks it's full when it's not) after being full for 24+ hours, now, about 10+ hours, and it doesn't matter if the server was continuously full or not. Whatever DICE "fixed", they made this problem worse.

Cain
This is my homepage
This is my homepage
Posts: 183
Joined: Sat Sep 01, 2012 6:27 am

Re: Server Connecting Problems

Post by Cain » Sun Jan 19, 2014 6:57 am

Tim, here is an interesting post from Reddit, I think discusses the issue you were asking about:

http://www.reddit.com/r/battlefield_4/c ... _an_admin/

Image

Post Reply