Can't connect to my TS3 Server with IP?

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 4:32 pm

I recently installed a Teamspeak3 server onto my VPS but when I try and connect to it with the IP it doesn't let me connect and provides me an error that says, "Failed to connect to server". You can try it for yourself if you'd like. The IP to my teamspeak should be 162.248.95.211 as it shows;
Image
If you know why it is doing this please share with me as it is frustrating not knowing why I can't connect to the server with the IP that it is.
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 4:40 pm

I know you're using Centos 7.1 (as stated in previous posts) have you tried forwarding the following ports required by TS3 via firewalld?

VoiceServer - 9987 (UDP)
ServerQuery - 10011 (TCP)
FileTransfer - 30033 (TCP)

Code: Select all

# firewall-cmd --zone=public --add-forward-port=port=9987:proto=UDP:toport=9987
# firewall-cmd --zone=public --add-forward-port=port=10011:proto=TCP:toport=10011
# firewall-cmd --zone=public --add-forward-port=port=30033:proto=TCP:toport=30033

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 4:57 pm

Markie wrote:I know you're using Centos 7.1 (as stated in previous posts) have you tried forwarding the following ports required by TS3 via firewalld?

VoiceServer - 9987 (UDP)
ServerQuery - 10011 (TCP)
FileTransfer - 30033 (TCP)

Code: Select all

# firewall-cmd --zone=public --add-forward-port=port=9987:proto=UDP:toport=9987
# firewall-cmd --zone=public --add-forward-port=port=10011:proto=TCP:toport=10011
# firewall-cmd --zone=public --add-forward-port=port=30033:proto=TCP:toport=30033
No I don't think I have. The tutorial I went through to install it did not state this as I could not find a tutorial for it here on NFO knowledgebase. I will try to do this now.
Image

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 5:14 pm

lowheartrate wrote:
Markie wrote:I know you're using Centos 7.1 (as stated in previous posts) have you tried forwarding the following ports required by TS3 via firewalld?

VoiceServer - 9987 (UDP)
ServerQuery - 10011 (TCP)
FileTransfer - 30033 (TCP)

Code: Select all

# firewall-cmd --zone=public --add-forward-port=port=9987:proto=UDP:toport=9987
# firewall-cmd --zone=public --add-forward-port=port=10011:proto=TCP:toport=10011
# firewall-cmd --zone=public --add-forward-port=port=30033:proto=TCP:toport=30033
No I don't think I have. The tutorial I went through to install it did not state this as I could not find a tutorial for it here on NFO knowledgebase. I will try to do this now.
I added those firewall cmds but still cannot connect to the server. Perhaps you would like to see the tutorial that I used in order to install it? http://forum.teamspeak.com/showthread.p ... ver-CentOS
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 5:23 pm

Apologies, did you also try restarting the firewalld service?

Code: Select all

# firewall-cmd --reload

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 5:30 pm

Also, I'm not receiving a response via telnet connection towards the IP/port, can you confirm that the TS3 process is currently running? You can check by running the following command;

Code: Select all

# ps -aux

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 5:41 pm

Markie wrote:Also, I'm not receiving a response via telnet connection towards the IP/port, can you confirm that the TS3 process is currently running? You can check by running the following command;

Code: Select all

# ps -aux
I reloading the firewall and here is a pastebin of what was echo'd when I used that cmd: http://pastebin.com/vipJvGgk
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 5:51 pm

I'm seeing that your TS3 server is running on root? The guide uses user "ts3srv", did you intend for it to run on root?

Code: Select all

root     12641  1.1  1.8 704320 18304 pts/1    Sl   21:13   0:18 ./ts3server_linux_amd64
Last edited by Markie on Fri Aug 07, 2015 5:53 pm, edited 1 time in total.

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 5:52 pm

Markie wrote:I'm seeing that your TS3 server is running on root? The guide uses user "ts3srv", did you intend for it to run on root?
No I did not :( Do you know how to fix this so I run it on the ts3srv user?
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 5:59 pm

First you're going to want to kill the TS3 service;

Code: Select all

# kill 12641
When you're starting up the server, you want to switch to the correct account beforehand;

Code: Select all

# su ts3srv
Then go ahead and run the TS3 server;

Code: Select all

# /home/ts3srv/teamspeak3-server_linux-amd64/ts3server_startscript.sh start

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 6:03 pm

Markie wrote:First you're going to want to kill the TS3 service;

Code: Select all

# kill 12641
When you're starting up the server, you want to switch to the correct account beforehand;

Code: Select all

# su ts3srv
Then go ahead and run the TS3 server;

Code: Select all

# /home/ts3srv/teamspeak3-server_linux-amd64/ts3server_startscript.sh start
I did the following instructions you gave me but am receiving an error trying to start it.

Code: Select all

[root@heartfx teamspeak3-server_linux-amd64]# kill 12641
[root@heartfx teamspeak3-server_linux-amd64]# su - ts3srv
Last login: Fri Aug  7 21:10:12 EDT 2015 on pts/1
-bash-4.2$ /home/ts3srv/teamspeak3-server_linux-amd64/ts3server_startscript.sh start
ts3server.pid found, but no server running. Possibly your previously started server crashed
Please view the logfile for details.
rm: remove write-protected regular file ‘ts3server.pid’?
My latest log file:

Code: Select all

2015-08-08 01:07:29.905773|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11.3 (2015-04-13 13:26:31)
2015-08-08 01:07:29.905881|INFO    |ServerLibPriv |   | SystemInformation: Linux 3.10.0-229.11.1.el7.x86_64 #1 SMP Thu Aug 6 01:06:18 UTC 2015 x86_64 Binary: 64bit
2015-08-08 01:07:29.905918|INFO    |ServerLibPriv |   | Using hardware aes
2015-08-08 01:07:29.906581|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
2015-08-08 01:07:29.906621|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
2015-08-08 01:07:29.912018|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
2015-08-08 01:07:29.925882|INFO    |SQL           |   | db_CreateTables() tables created
2015-08-08 01:07:30.086895|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
2015-08-08 01:07:32.171253|INFO    |              |   | Puzzle precompute time: 1572
2015-08-08 01:07:32.171861|INFO    |FileManager   |   | listening on 0.0.0.0:30033
2015-08-08 01:07:32.175424|INFO    |VirtualSvrMgr |   | executing monthly interval
2015-08-08 01:07:32.175544|INFO    |VirtualSvrMgr |   | reset virtualserver traffic statistics
2015-08-08 01:07:32.337641|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
2015-08-08 01:07:32.337970|INFO    |Query         |   | listening on 0.0.0.0:10011
2015-08-08 01:08:59.274792|INFO    |ServerMain    |   | Received signal SIGTERM, shutting down.
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 6:16 pm

Delete the .pid file from your /home/ts3srv/teamspeak3-server_linux-amd64/ directory and try starting the server again.

Additionally, I'd recommend creating an auto startup script;

Code: Select all

# vi /etc/rc.d/init.d/teamspeak

Code: Select all

#!/bin/sh
# chkconfig: 2345 99 10
USER="ts3srv"
TS3='/home/ts3srv/teamspeak3-server_linux-amd64'
STARTSCRIPT="$TS3/ts3server_startscript.sh"
cd $TS3
case "$1" in
'start')
su $USER -c "$STARTSCRIPT start"
;;
'stop')
su $USER -c "$STARTSCRIPT stop"
;;
'restart')
su $USER -c "$STARTSCRIPT restart"
;;
'status')
su $USER -c "$STARTSCRIPT status"
;;
*)
echo "Usage $0 start|stop|restart|status"
esac
Lets not forget to give it the correct permissions;

Code: Select all

# chmod 0755 /etc/rc.d/init.d/teamspeak
Afterwards don't forget to run the following commands;

Code: Select all

# chkconfig --add teamspeak

Code: Select all

# chkconfig --level 2345 teamspeak on

Code: Select all

# service teamspeak start

lowheartrate
A semi-regular
A semi-regular
Posts: 28
Joined: Thu Jul 02, 2015 2:54 pm
Contact:

Re: Can't connect to my TS3 Server with IP?

Post by lowheartrate » Fri Aug 07, 2015 6:23 pm

Markie wrote:Delete the .pid file from your /home/ts3srv/teamspeak3-server_linux-amd64/ directory and try starting the server again.

Additionally, I'd recommend creating an auto startup script;

Code: Select all

# vi /etc/rc.d/init.d/teamspeak

Code: Select all

#!/bin/sh
# chkconfig: 2345 99 10
USER="ts3srv"
TS3='/home/ts3srv/teamspeak3-server_linux-amd64'
STARTSCRIPT="$TS3/ts3server_startscript.sh"
cd $TS3
case "$1" in
'start')
su $USER -c "$STARTSCRIPT start"
;;
'stop')
su $USER -c "$STARTSCRIPT stop"
;;
'restart')
su $USER -c "$STARTSCRIPT restart"
;;
'status')
su $USER -c "$STARTSCRIPT status"
;;
*)
echo "Usage $0 start|stop|restart|status"
esac
Lets not forget to give it the correct permissions;

Code: Select all

# chmod 0755 /etc/rc.d/init.d/teamspeak
Afterwards don't forget to run the following commands;

Code: Select all

# chkconfig --add teamspeak

Code: Select all

# chkconfig --level 2345 teamspeak on

Code: Select all

# service teamspeak start
Hmm now I am in the /etc/rc.d/init.d/ directory and do not see anything regarding Teamspeak3. Seeming this is taking me forever to accomplish myself would you offer to do it for me for a small payment via PayPal? I am not sure I understand this fully as you do. If you are willing to help me out feel free to add me on Skype or connect to my other teamspeak to talk to me. My Skype name is lowheartrate and my current teamspeak server address is 104.243.24.204
Image

User avatar
Markie
A regular
A regular
Posts: 56
Joined: Mon Oct 01, 2012 11:55 am
Location: AS14586

Re: Can't connect to my TS3 Server with IP?

Post by Markie » Fri Aug 07, 2015 6:29 pm

I would be more then happy to do this for you, but I won't take your money =p.. I will be contacting you shortly.

Sena
New to forums
New to forums
Posts: 2
Joined: Sat May 21, 2016 12:24 pm

Re: Can't connect to my TS3 Server with IP?

Post by Sena » Sat May 21, 2016 12:34 pm

Could you also help me out? i'm having a issue alike to his.
I would really appreciate that, i'm no linux genius and i've been struggling with it for the past 2 days now, the Server was running all good and well and then shit hit the wall when i turned it off and moved it into the livingroom, ever since then i can't connect... the server says it's running, but i (and noone else) can join it.

Code: Select all

drwx------ 3 esel esel 4096 Mai 21 20:11 internal
drwx------ 4 esel root 4096 Mai 20 23:27 virtualserver_1
drwx------ 4 esel root 4096 Mai 21 19:42 virtualserver_3

Code: Select all

-rw-rw-r-- 1 esel esel   47909 Apr 25 17:19 CHANGELOG
drwxrwxr-x 3 esel esel    4096 Apr 22 14:31 doc
drwx------ 5 esel root    4096 Mai 21 20:11 files
-rwxrwxr-x 1 esel esel  988528 Apr 25 17:19 libts3db_mariadb.so
-rwxrwxr-x 1 esel esel 2019584 Apr 25 17:19 libts3db_sqlite3.so
-rw-rw-r-- 1 esel esel   36710 Apr 25 17:19 LICENSE
drwxrwxrwx 2 esel root    4096 Mai 21 20:16 logs
-rw-r--r-- 1 esel root       1 Mai 20 23:27 query_ip_blacklist.txt
-rw-r--r-- 1 esel root      10 Mai 20 23:27 query_ip_whitelist.txt
drwxrwxr-x 2 esel esel    4096 Apr 25 17:19 redist
drwxrwxr-x 2 esel esel    4096 Apr 22 14:31 serverquerydocs
drwxrwxr-x 5 esel esel    4096 Apr 22 14:31 sql
-rwxrwxr-x 1 esel esel 8212624 Apr 25 17:19 ts3server
-rwxrwxr-x 1 esel esel     129 Apr 25 17:19 ts3server_minimal_runscript.sh
-rw-r--r-- 1 esel esel       5 Mai 21 20:16 ts3server.pid
-rw-r--r-- 1 esel esel  190464 Mai 21 19:42 ts3server.sqlitedb
-rwxrwxr-x 1 esel esel    2661 Apr 25 17:19 ts3server_startscript.sh
drwxrwxr-x 2 esel esel    4096 Apr 25 17:19 tsdns

Code: Select all

2016-05-21 19:57:23.102951|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.0.12.4 (2016-04-25 15:16:45)
2016-05-21 19:57:23.103242|INFO    |ServerLibPriv |   |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 Binary: 64bit
2016-05-21 19:57:23.104937|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
2016-05-21 19:57:23.105060|INFO    |DatabaseQuery |   |dbPlugin version: 3.8.6
2016-05-21 19:57:23.105508|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
2016-05-21 19:57:23.142255|WARNING |Accounting    |   |Unable to find valid license key, falling back to limited functionality
2016-05-21 19:57:25.089595|INFO    |              |   |Puzzle precompute time: 1784
2016-05-21 19:57:25.090274|INFO    |FileManager   |   |listening on 0.0.0.0:30033
2016-05-21 19:57:25.138256|ERROR   |FileHelp      |   |CustomFileHelpers::createDirectory _wmkdir files/virtualserver_3/internal/icons -1 13
2016-05-21 19:57:25.138605|ERROR   |VirtualSvrMgr |   |loading VirtualServer(3) failed to start, error: invalid file path
2016-05-21 19:57:25.139129|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1,
2016-05-21 19:57:25.140139|INFO    |Query         |   |listening on 0.0.0.0:10011

Code: Select all

2016-05-21 19:57:25.138380|ERROR   |VirtualServer |3  |Unable to create virtualserver filetransfer internal/icons directory. Error: 2052 dir: files/virtualserver_3
2016-05-21 19:57:25.138864|INFO    |VirtualServerBase|3  |stopped
This is all i have, if you could help me in any way, i would really appreciate that.

Post Reply